knrt.net
当前位置:首页 >> CAnnt FinD lCrypto >>

CAnnt FinD lCrypto

按照提示好像是因为无法在系统路径找到 MariaDB(mysql)的相关库文件.两种办法处理:1. 安装 mysql-devel.rpm 2.如果你是源码安装的mysql,修改系统 LD_LIBRARY_PATH值,把你mysql的路径也加入.加入你的mysql安装在 /user/local/mysql

哥门 <openssl/aes.h> 里 的openssl只是文件夹名字而已,在linux下面 /usr/local/include/ /usr/include/ 这两个路径是默认引用的.所以你没加 -I 也是可以编译的 .当交叉编译时,那就完全不一样了,必须配置好所有路径.

php5.6如果有rpm包的话,可以yum安装,不过好像rpm包版本没有呢么高,这样你就要下载php的 源码包自己编译安装了,有一些三方源可能有那么高版本的php,,这个需要换源,看你想怎么安装

-lcrypto是缺少库libcrypto.so吧你这用什么系统编的啊为什么执行命令看是linux 底下还有D盘程序里也有错误啊jni/OpensslWapper.cpp:102: error: undefined reference to 'BN_bn2hex'

把编译参数贴出来.(试下yum install -y openssl-devel再试试)

相关文档
网站首页 | 网站地图
All rights reserved Powered by www.knrt.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com