knrt.net
当前位置:首页 >> linux liBxml2 DEvEl >>

linux liBxml2 DEvEl

先装zlib-devel包

检查一下默认系统是有的: [root@~ 15:18]#find / -name "libxml2*"/usr/lib64/libxml2.so/usr/lib64/libxml2.so.2/usr/lib64/libxml2.so.2.7.6/usr/share/doc/libxml2-devel-2.7.6/usr/share/doc/libxml2-devel-2.7.6/libxml2-api.xml.gz/usr/s...

最新的是2.9.2-5 跟自己的比较一下就知道了

哪个版本的linux?一般linux发行版都自带libxml2的,从光盘上装就可以了,比如centos6.x就有: libxml2-2.7.6-8.el6_3.4.i686.rpm libxml2-2.7.6-8.el6_3.4.i686.rpm libxml2-devel-2.7.6-8.el6_3.4.i686.rpm libxml2-devel-2.7.6-8.el6_3.4.x86...

看报错应该是你选取的源访问速度太慢,换一个yum源试试

rpm -q libxml2

假设libxml2 库放在 /user/lib 目录下,则可以像下面这种方式包含libxml2 这个库在你的*.pro文件中,加入下面这一行: LIBS += /user/lib/libxml2.lib 然后在你工程中包含libxml2的头文件。 可以试下,我还没试过。好久没用Linux了。 如果上面的...

直接用 yum 安装 php好了。yum 可以自己解依赖关系

把linux下面的python从2.4更新到2.7了,然后用sudo yum install libxml2-python命令安装libxml2每次都提示成功,但是进入到python环境输入import libxml2都提示错误,后来发现用yum install 安装默认安装到了python2.4下面的site-packages下

你的命令没有问题。 rpm-5.1.6.tar.gz不是rpm包,是一个gz的压缩包,用tar -xzvf rpm-5.1.6.tar.gz是可以解压成功的。 如果你要装rpm包,应该是 rpm -ivh 包名,或者你那个rpm-5.1.6.tar.gz原本是rpm包,后来被重命名了,你用rpm -ivh rpm-5.1.6....

网站首页 | 网站地图
All rights reserved Powered by www.knrt.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com